E:Unable to Locate Package

Решил купить выделенный сервер для тестирования одного проекта. Хостинг дал на выбор несколько unix дистрибутивов, выбрал самый последний из имеющихся Ubuntu 12.0

В процессе установки необходимого софта через apt-get install постоянно вылезала ошибка E:Unable to Locate Package.

Причем при установке чего то обычно, к примеру nano или mc все ставилось без ошибки, а когда пробовал такие вещи как git, itext и т.п. получал ошибку.

Долго мучился, даже другой хостинг пробовал, в итоге вся проблема была в наличии репозиториев в файле /etc/apt/sources.list

Так как до этого я ставил программу на локальном сервере и там все заработало, решил просто копировать файл от туда на удаленную машину.

Обязательно после сохранения файла сделайте update:

 

Добавить комментарий